$re = '/[^( \t]+(?:[ \t]+[^( \t]+)*/';
$str = 'Test Tester AndTest (2552)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);