const regex = /(?:\b(?:(kilogram\.*s*\.*|kg\.*s*\.*)(?:[^[:alnum:]])*)(?:\s*weight\s*)*(?:\s*is\s*|\s*are\s*)*)\W*([\d\.,]*\d+\b)|(?:(?:[\s\.]?|^)([\d\.,]*\d+)\W*(kilogram\.*s*\.*|kg\.*s*\.*)\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:\\b(?:(kilogram\\.*s*\\.*|kg\\.*s*\\.*)(?:[^[:alnum:]])*)(?:\\s*weight\\s*)*(?:\\s*is\\s*|\\s*are\\s*)*)\\W*([\\d\\.,]*\\d+\\b)|(?:(?:[\\s\\.]?|^)([\\d\\.,]*\\d+)\\W*(kilogram\\.*s*\\.*|kg\\.*s*\\.*)\\b)', 'gm')
const str = `15kilograms fs s
kg 10 fe
something 10.5 kg-fef
11.55kg gfre
11.55-kg gfre
11.55 kg gfre
kg 11.25 gre
efewf kg 11 fweew
ewsfewf kg
55 few
kg-55.55 dwd
eeewegv kg 55.55 ee
fewfewff 10
kg feeee
smth. .15kg ewfcwe
something kilogram weight is 15.5
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}