use strict;
my $str = '15kilograms fs s
kg 10 fe
something 10.5 kg-fef
11.55kg gfre
11.55-kg gfre
11.55 kg gfre
kg 11.25 gre
efewf kg 11 fweew
ewsfewf kg
55 few
kg-55.55 dwd
eeewegv kg 55.55 ee
fewfewff 10
kg feeee
smth. .15kg ewfcwe
something kilogram weight is 15.5
';
my $regex = qr/(?:\b(?:(kilogram\.*s*\.*|kg\.*s*\.*)(?:[^[:alnum:]])*)(?:\s*weight\s*)*(?:\s*is\s*|\s*are\s*)*)\W*([\d\.,]*\d+\b)|(?:(?:[\s\.]?|^)([\d\.,]*\d+)\W*(kilogram\.*s*\.*|kg\.*s*\.*)\b)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}