re = /(?P<start>Hello, I have)(?P<middle>.+?)(?P<end>car)/m
str = 'Hello, I have a very expensive car'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end