package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)INC|INC$|INC$|LTD$|CORP$|CORPORATION$|COMPANY$|LLC$|\*LLC$|\*,INC$|\*,CORP$|\*LTD$|\*CORP$|LEASING|TRANSPORTATION|CONSULTANTS|SERVICES|INCORPORATED`)
var str = `xxx, INC`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}