re = /INC|INC$|INC$|LTD$|CORP$|CORPORATION$|COMPANY$|LLC$|\*LLC$|\*,INC$|\*,CORP$|\*LTD$|\*CORP$|LEASING|TRANSPORTATION|CONSULTANTS|SERVICES|INCORPORATED/m
str = 'xxx, INC'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end