package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\S+@\S+`)
var str = `' for somebody@domain.com for somebody@domain.com '`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}