$re = '/\S+@\S+/m';
$str = '\' for somebody@domain.com for somebody@domain.com \'';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);