import re
regex = re.compile(r"\s*(?:\"([^\"]*)\"|([^,\"\"<>]*))?\s*(?:(?:,|<|\s+|^)([^<@\s,]+@[^>@\s,]+)>?)\s*", flags=re.MULTILINE)
test_str = ("Test1 <test1@x.com>, Test Two test2@x.y.com,T e s t 3 <test3@z.com>, Test@4 <test4@abc.com>, test5@cde.com,\n"
"\"Bob Smith\" <bob@company.com>, joe@company.com, \"John Doe\"<john@company.com>, Billy Doe<billy@company.com>\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")