using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=key=).*?(?=&|$)";
string input = @"https://www.example.com/demo/#!/~/signIn/key=RtS1OMW9Tn2q&returnUrl=account/favorites";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}