#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?um)(([\w\s]+)\(([1|2]\d{3})\))(.*)"
Local $sString = "Abbott A (1988) The System of Professions: An Essay on the Division of Expert Labor. Chicago," & @CRLF & _
"IL: University of Chicago Press." & @CRLF & _
"Albu OB and Flyverbom M (2016) Organizational transparency: conceptualizations, con-" & @CRLF & _
"ditions, and consequences. Business & Society. Epub ahead of print 13 July. DOI:" & @CRLF & _
"10.1177/0007650316659851." & @CRLF & _
"Ananny M (2016) Toward an ethics of algorithms: convening, observation, probability, and timeli-" & @CRLF & _
"ness. Science, Technology & Human Values 41(1): 93–117. DOI: 10.1177/0162243915606523." & @CRLF & _
"Anderson CW (2013) Towards a sociology of computational and algorithmic journalism. New" & @CRLF & _
"Media & Society 15(7): 1005–1021. DOI: 10.1177/1461444812465137." & @CRLF & _
"Arnoldi J (2015) Computer algorithms, market manipulation and the institutionalization of high" & @CRLF & _
"frequency trading. Theory, Culture & Society 33: 29–52." & @CRLF & _
"Bacon M (2012) Pragmatism. Cambridge: Polity Press." & @CRLF & _
"Baecker R (1998) Sorting out sorting: a case study of software visualization for teaching computer" & @CRLF & _
"science. In: Stasko J (ed.) Software Visualization Programming as a Multimedia Experience." & @CRLF & _
"Cambridge, MA: The MIT Press, pp. 369–381." & @CRLF & _
"Ball C (2009) What is transparency? Public Integrity 11(4): 293–308." & @CRLF & _
"Barany MJ and MacKenzie D (2014) Chalk: materials and concepts in mathematics research. In:" & @CRLF & _
"Coopmans C, Vertesi J, Lynch M, et al. (eds) Representation in Scientific Practice Revisited." & @CRLF & _
"Cambridge, MA: The MIT Press, pp. 107–130." & @CRLF & _
"Bateson G (2000) Steps to an Ecology of Mind: Collected Essays in Anthropology, Psychiatry," & @CRLF & _
"Evolution, and Epistemology. Chicago, IL: University of Chicago Press." & @CRLF & _
"Birchall C (2011) Introduction to “secrecy and transparency”: the politics of opacity and openness." & @CRLF & _
"Theory, Culture & Society 28(7–8): 7–25." & @CRLF & _
"Birchall C (2014) Radical transparency? Cultural Studies ↔ Critical Methodologies 14(1): 77–88." & @CRLF & _
"Bratich J (2016) Occult(ing) transparency: an epilogue. International Journal of Communication" & @CRLF & _
"Systems 10: 178–181." & @CRLF & _
"Brill J (2015) Scalable approaches to transparency and accountability in decisionmaking algo-" & @CRLF & _
"rithms: remarks at the NYU conference on algorithms and accountability. Federal Trade" & @CRLF & _
"Commission, 28 February. Available at: https://www.ftc.gov/system/files/documents/pub-" & @CRLF & _
"lic_statements/629681/150228nyualgorithms.pdf" & @CRLF & _
"Brown MH (1998) A taxonomy of algorithm animation displays. In: Stasko J (ed.) Software" & @CRLF & _
"Visualization Programming as a Multimedia Experience. Cambridge, MA: The MIT Press," & @CRLF & _
"pp. 35–42." & @CRLF & _
"Browne S (2015) Dark Matters: On the Surveillance of Blackness. Durham, NC: Duke University" & @CRLF & _
"Press." & @CRLF & _
"Burrell J (2016) How the machine “thinks”: understanding opacity in machine learning algorithms." & @CRLF & _
"Big Data & Society 3(1). DOI: 10.1177/2053951715622512." & @CRLF & _
"Carusi A and Hoel AS (2014) Toward a new ontology of scientific vision. In: Coopmans C, Vertesi" & @CRLF & _
"J, Lynch M, et al. (eds) Representation in Scientific Practice Revisited. Cambridge, MA: The" & @CRLF & _
"MIT Press, pp. 201–221." & @CRLF & _
"Christensen LT and Cheney G (2015) Peering into transparency: challenging ideals, proxies, and" & @CRLF & _
"organizational practices. Communication Theory 25(1): 70–90." & @CRLF & _
"Coddington M (2012) Defending a paradigm by patrolling a boundary: two global newspapers’" & @CRLF & _
"approach to WikiLeaks. Journalism & Mass Communication Quarterly 89(3): 377–396." & @CRLF & _
"Coleman G (2013) Coding Freedom: The Ethics and Aesthetics of Hacking. Princeton, NJ:" & @CRLF & _
"Princeton University Press." & @CRLF & _
"Coopmans C, Vertesi J, Lynch M, et al. (2014) Introduction. In: Coopmans C, Vertesi J, Lynch M," & @CRLF & _
"et al. (eds) Representation in Scientific Practice Revisited. Cambridge, MA: The MIT Press," & @CRLF & _
"pp. 1–12." & @CRLF & _
"Crain M (2016) The limits of transparency: data brokers and commodification. New Media &" & @CRLF & _
"Society. Epub ahead of print 7 July. DOI: 10.1177/1461444816657096." & @CRLF & _
"Crain W (2000) Theories and Development: Concepts and Applications. Upper Saddle River, NJ:" & @CRLF & _
"Prentice Hall." & @CRLF & _
"Crary J (1990) Techniques of the Observer. Cambridge, MA: The MIT Press." & @CRLF & _
"Crawford K (2016) Can an algorithm be agonistic? Ten scenes from life in calculated publics." & @CRLF & _
"Science, Technology & Human Values 41(1): 77–92." & @CRLF & _
"da Vinci L (2015) Notebooks of Leonardo Da Vinci (trans. JP Richter). Istanbul: eKitap Projesi." & @CRLF & _
"Daston L (1992) Objectivity and the escape from perspective. Social Studies of Science 22(4):" & @CRLF & _
"597–618." & @CRLF & _
"Daston L and Galison P (2007) Objectivity. Brooklyn, NY: Zone Books." & @CRLF & _
"Datta A, Tschantz MC and Datta A (2015) Automated experiments on ad privacy settings." & @CRLF & _
"Proceedings on Privacy Enhancing Technologies 1: 92–112." & @CRLF & _
"David M (2015) The correspondence theory of truth. Stanford Encyclopedia of Philosophy, 28" & @CRLF & _
"May Available at: http://plato.stanford.edu/entries/truth-correspondence/" & @CRLF & _
"De Rijcke S and Beaulieu A (2014) Networked neuroscience: brain scans and visual knowing at" & @CRLF & _
"the intersection of atlases and databases. In: Coopmans C, Vertesi J, Lynch M, et al. (eds)" & @CRLF & _
"Representation in Scientific Practice Revisited. Cambridge, MA: The MIT Press, pp. 131–" & @CRLF & _
"152." & @CRLF & _
"Dewey J (1997) Experience and Education. New York: Free Press." & @CRLF & _
"Diakopoulos N (2016) Accountability in algorithmic decision making. Communications of the" & @CRLF & _
"ACM 59(2): 56–62." & @CRLF & _
"DiSalvo C (2012) Adversarial Design. Cambridge, MA: The MIT Press." & @CRLF & _
"Dougherty C (2015) Google photos mistakenly labels black people “gorillas.” The New York" & @CRLF & _
"Times, 1 July. Available at: http://bits.blogs.nytimes.com/2015/07/01/google-photos-mistak-" & @CRLF & _
"enly-labels-black-people-gorillas/" & @CRLF & _
"Driscoll K and Walker S (2014) Working within a black box: transparency in the collection" & @CRLF & _
"and production of big Twitter data. International Journal of Communication Systems 8:" & @CRLF & _
"1745–1764." & @CRLF & _
"Eslami M, Rickman A, Vaccaro K, et al. (2015) “I always assumed that I wasn’t really that close" & @CRLF & _
"to [her]”: reasoning about invisible algorithms in the news feed. In: Proceedings of the 33rd" & @CRLF & _
"annual ACM conference on human factors in computing systems, Seoul, Republic of Korea," & @CRLF & _
"18–23 April." & @CRLF & _
"Flyverbom M (2016) Transparency: mediation and the management of visibilities. International" & @CRLF & _
"Journal of Communication Systems 10: 110–122." & @CRLF & _
"Fox J (2007) The uncertain relationship between transparency and accountability. Development in" & @CRLF & _
"Practice 17(4–5): 663–671." & @CRLF & _
"Fung A, Graham M and Weil D (2008) Full Disclosure: The Perils and Promise of Transparency." & @CRLF & _
"Cambridge: Cambridge University Press." & @CRLF & _
"Gillespie T (2014) The relevance of algorithms. In: Gillespie T, Boczkowski P and Foot KA (eds)" & @CRLF & _
"Media Technologies: Essays on Communication, Materiality, and Society. Cambridge, MA:" & @CRLF & _
"The MIT Press, pp. 167–194." & @CRLF & _
"Glasser TL (1989) Three views on accountability. In: Dennis EE, Gillmor DM and Glasser TL" & @CRLF & _
"(eds) Media Freedom and Accountability. New York: Praeger." & @CRLF & _
"Goodwin C (1994) Professional vision. American Anthropologist 96(3): 606–633." & @CRLF & _
"Greenwald G (2014) No Place to Hide. New York: Metropolitan Books." & @CRLF & _
"Hallinan B and Striphas T (2014) Recommended for you: the Netflix Prize and the production of" & @CRLF & _
"algorithmic culture. New Media & Society 18: 117–137." & @CRLF & _
"Hansen HK and Flyverbom M (2015) The politics of transparency and the calibration of knowl-" & @CRLF & _
"edge in the digital age. Organization 22(6): 872–889." & @CRLF & _
"Heald D (2006) Varieties of transparency. Proceedings of the British Academy 135: 25–43." & @CRLF & _
"Heemsbergen L (2016) From radical transparency to radical disclosure: reconfiguring (in)vol-" & @CRLF & _
"untary transparency through the management of visibilities. International Journal of" & @CRLF & _
"Communication Systems 10: 138–151." & @CRLF & _
"Hilgartner S (2000) Science on Stage: Expert Advice as Public Drama. Stanford, CA: Stanford" & @CRLF & _
"University Press." & @CRLF & _
"Hood C (2006) Transparency in historical perspective. In: Hood C and Heald D (eds) Transparency:" & @CRLF & _
"The Key to Better Governance? Oxford: Oxford University Press, pp. 1–23." & @CRLF & _
"James W (1997) What pragmatism means. In: Menand L (ed.) Pragmatism: A Reader. New York:" & @CRLF & _
"Random House, pp. 93–111." & @CRLF & _
"Kelty C (2008) Two Bits: The Cultural Significance of Free Software. Durham, NC: Duke" & @CRLF & _
"University Press." & @CRLF & _
"Kushner S (2013) The freelance translation machine: algorithmic culture and the invisible indus-" & @CRLF & _
"try. New Media & Society 15: 1241–1258." & @CRLF & _
"Leigh D and Harding L (2011) WikiLeaks: Inside Julian Assange’s War on Secrecy. New York:" & @CRLF & _
"Public Affairs." & @CRLF & _
"Levy KEC (2015) The contexts of control: information, power, and truck-driving work. Information" & @CRLF & _
"Society 31(2): 160–174." & @CRLF & _
"Levy KEC and Johns DM (2016) When open data is a Trojan Horse: the weaponization of trans-" & @CRLF & _
"parency in science and governance. Big Data & Society 3(1). http://bds.sagepub.com/con-" & @CRLF & _
"tent/3/1/2053951715621568" & @CRLF & _
"Lynch M and Woolgar S (1988) Introduction: sociological orientations to representational practice" & @CRLF & _
"in science. Human Studies 11(2): 99–116." & @CRLF & _
"Mackenzie A (2015) The production of prediction: what does machine learning want? European" & @CRLF & _
"Journal of Cultural Studies 18(4–5): 429–445." & @CRLF & _
"Mackenzie D (2008) An Engine, Not a Camera: How Financial Models Shape Markets. Cambridge," & @CRLF & _
"MA: The MIT Press." & @CRLF & _
"Michaels D (2008) Doubt Is Their Product: How Industry’s Assault on Science Threatens Your" & @CRLF & _
"Health. Oxford: Oxford University Press." & @CRLF & _
"Minsky M (2007) The Emotion Machine: Commonsense Thinking, Artificial Intelligence, and the" & @CRLF & _
"Future of the Human Mind. New York: Simon & Schuster." & @CRLF & _
"Misak C (ed.) (2007) New Pragmatists. Oxford: Oxford University Press." & @CRLF & _
"Napoli PM (2014) Automated media: an institutional theory perspective on algorithmic media" & @CRLF & _
"production and consumption. Communication Theory 24(3): 340–360." & @CRLF & _
"Neyland D and Möllers N (2016) Algorithmic IF ... THEN rules and the conditions and conse-" & @CRLF & _
"quences of power. Information, Communication & Society, 20 (1): 45-62." & @CRLF & _
"Papert S (1980) Mindstorms: Children, Computers, and Powerful Ideas. New York: Basic" & @CRLF & _
"Books." & @CRLF & _
"Pasquale F (2015) The Black Box Society: The Secret Algorithms That Control Money and" & @CRLF & _
"Information. Cambridge, MA: Harvard University Press." & @CRLF & _
"Phillips JWP (2011) Secrecy and transparency: an interview with Samuel Weber. Theory, Culture" & @CRLF & _
"& Society 28(7–8): 158–172." & @CRLF & _
"Resnick M, Berg R and Eisenberg M (2000) Beyond black boxes: bringing transparency and aes-" & @CRLF & _
"thetics back to scientific investigation. Journal of the Learning Sciences 9(1): 7–30." & @CRLF & _
"Schnackenberg AK and Tomlinson EC (2014) Organizational transparency: a new perspective" & @CRLF & _
"on managing trust in organization-stakeholder relationships. Journal of Management 42:" & @CRLF & _
"1784–1810." & @CRLF & _
"Schrock AR (2016) Civic hacking as data activism and advocacy: a history from publicity to open" & @CRLF & _
"government data. New Media & Society 18: 581–599." & @CRLF & _
"Schudson M (2015) The Rise of the Right to Know. Cambridge, MA: Belknap Publishing." & @CRLF & _
"Squires CR (2002) Rethinking the black public sphere: an alternative vocabulary for multiple" & @CRLF & _
"public spheres. Communication Theory 12(4): 446–468." & @CRLF & _
"Stiny G (1980) Kindergarten grammars: designing with Froebel’s building gifts. Environment and" & @CRLF & _
"Planning B 7(4): 409–462." & @CRLF & _
"Stohl C, Stohl M and Leonardi PM (2016) Managing opacity: information visibility and the para-" & @CRLF & _
"dox of transparency in the digital age. International Journal of Communication Systems 10:" & @CRLF & _
"123–137." & @CRLF & _
"Striphas T (2015) Algorithmic culture. European Journal of Cultural Studies 18(4–5): 395–412." & @CRLF & _
"Tkacz N (2015) Wikipedia and the Politics of Openness. Chicago, IL: University of Chicago Press." & @CRLF & _
"Turner F (2006) From Counterculture to Cyberculture: Stewart Brand, the Whole Earth Network," & @CRLF & _
"and the Rise of Digital Utopianism. Chicago, IL: University of Chicago Press." & @CRLF & _
"Turner F (2013) The Democratic Surround. Chicago, IL: University of Chicago Press." & @CRLF & _
"Vertesi J (2014) Drawing as: distinctions and disambiguation in digital images of Mars. In:" & @CRLF & _
"Coopmans C, Vertesi J, Lynch M, et al. (eds) Representation in Scientific Practice Revisited." & @CRLF & _
"Cambridge, MA: The MIT Press, pp. 15–36." & @CRLF & _
"Wade L (2010) HP software doesn’t see black people. Sociological Images, 5 January. Available" & @CRLF & _
"at: https://thesocietypages.org/socimages/2010/01/05/hp-software-doesnt-see-black-people/" & @CRLF & _
"Ward SC (1996) Reconfiguring Truth. New York: Rowman & Littlefield." & @CRLF & _
"Zara C (2015) FTC chief technologist Ashkan Soltani on algorithmic transparency and the" & @CRLF & _
"fight against biased bots. International Business Times, 9 April. Available at: http://www." & @CRLF & _
"ibtimes.com/ftc-chief-technologist-ashkan-soltani-algorithmic-transparency-fight-against-" & @CRLF & _
"biased-1876177"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")