#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((([0-9A-Fa-f]{1,4}:){7}([0-9A-Fa-f]{1,4}|:))|(([0-9A-Fa-f]{1,4}:){6}(:[0-9A-Fa-f]{1,4}|((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3})|:))|(([0-9A-Fa-f]{1,4}:){5}(((:[0-9A-Fa-f]{1,4}){1,2})|:((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3})|:))|(([0-9A-Fa-f]{1,4}:){4}(((:[0-9A-Fa-f]{1,4}){1,3})|((:[0-9A-Fa-f]{1,4})?:((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3}))|:))|(([0-9A-Fa-f]{1,4}:){3}(((:[0-9A-Fa-f]{1,4}){1,4})|((:[0-9A-Fa-f]{1,4}){0,2}:((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3}))|:))|(([0-9A-Fa-f]{1,4}:){2}(((:[0-9A-Fa-f]{1,4}){1,5})|((:[0-9A-Fa-f]{1,4}){0,3}:((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3}))|:))|([0-9A-Fa-f]{1,4}:){1}(((:[0-9A-Fa-f]{1,4}){0,4}:((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3}))|((:[0-9A-Fa-f]{1,4}){1,6})|:)|(:(((:[0-9A-Fa-f]{1,4}){1,7})|((:[0-9A-Fa-f]{1,4}){0,5}:((25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)(\.(25[0-5]|2[0-4]\d|1\d\d|[1-9]?\d)){3}))|:)))"
Local $sString = "1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000" & @CRLF & _
" link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00" & @CRLF & _
" inet 127.0.0.1/8 scope host lo" & @CRLF & _
" valid_lft forever preferred_lft forever" & @CRLF & _
" inet6 ::1/128 scope host " & @CRLF & _
" valid_lft forever preferred_lft forever" & @CRLF & _
"2: enp4s0f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000" & @CRLF & _
" link/ether 00:17:31:f1:98:3c brd ff:ff:ff:ff:ff:ff" & @CRLF & _
"3: enp4s0f1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000" & @CRLF & _
" link/ether 00:17:31:f1:98:3d brd ff:ff:ff:ff:ff:ff" & @CRLF & _
"4: enp5s0f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000" & @CRLF & _
" link/ether 00:27:9e:b5:e6:da brd ff:ff:ff:ff:ff:ff" & @CRLF & _
" inet 5.2.14.1/29 brd 5.2.1.255 scope global noprefixroute enp5s0f0" & @CRLF & _
" valid_lft forever preferred_lft forever" & @CRLF & _
" inet6 fe80::5473:d653:a319:3d25/64 scope link noprefixroute " & @CRLF & _
" valid_lft forever preferred_lft forever" & @CRLF & _
"5: enp5s0f1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000" & @CRLF & _
" link/ether 00:26:9e:b5:e6:db brd ff:ff:ff:ff:ff:ff" & @CRLF & _
"27: ip_vti0@NONE: <NOARP> mtu 1480 qdisc noop state DOWN group default qlen 1000" & @CRLF & _
" link/ipip 0.0.0.0 brd 0.0.0.0" & @CRLF & _
"38: tunl0@NONE: <NOARP> mtu 1480 qdisc noop state DOWN group default qlen 1000" & @CRLF & _
" link/ipip 0.0.0.0 brd 0.0.0.0" & @CRLF & _
"50: tap0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 100" & @CRLF & _
" link/ether ea:04:cd:c5:81:fa brd ff:ff:ff:ff:ff:ff" & @CRLF & _
" inet 10.1.128.2/21 brd 10.1.135.255 scope global tap0" & @CRLF & _
" valid_lft forever preferred_lft forever" & @CRLF & _
" inet6 fe80::e804:cdff:fec5:81fa/64 scope link " & @CRLF & _
" valid_lft forever preferred_lft forever" & @CRLF & _
"fe80:0000:0000:0000:0204:61ff:fe9d:f156 // full form of IPv6" & @CRLF & _
"fe80:0:0:0:204:61ff:fe9d:f156 // drop leading zeroes" & @CRLF & _
"fe80::204:61ff:fe9d:f156 // collapse multiple zeroes to :: in the IPv6 address" & @CRLF & _
"fe80:0000:0000:0000:0204:61ff:254.157.241.86 // IPv4 dotted quad at the end" & @CRLF & _
"fe80:0:0:0:0204:61ff:254.157.241.86 // drop leading zeroes, IPv4 dotted quad at the end" & @CRLF & _
"fe80::204:61ff:254.157.241.86 // dotted quad at the end, multiple zeroes collapsed" & @CRLF & _
"" & @CRLF & _
"In addition, the regular expression matches these IPv6 forms:" & @CRLF & _
"" & @CRLF & _
"::1 // localhost" & @CRLF & _
"fe80:: // link-local prefix" & @CRLF & _
"2001:: // global unicast prefix" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")