import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((([0-9A-Fa-f]{1,4}:){7}([0-9A-Fa-f]{1,4}|:))|(([0-9A-Fa-f]{1,4}:){6}(:[0-9A-Fa-f]{1,4}|((25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)(\\.(25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)){3})|:))|(([0-9A-Fa-f]{1,4}:){5}(((:[0-9A-Fa-f]{1,4}){1,2})|:((25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)(\\.(25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)){3})|:))|(([0-9A-Fa-f]{1,4}:){4}(((:[0-9A-Fa-f]{1,4}){1,3})|((:[0-9A-Fa-f]{1,4})?:((25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)(\\.(25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)){3}))|:))|(([0-9A-Fa-f]{1,4}:){3}(((:[0-9A-Fa-f]{1,4}){1,4})|((:[0-9A-Fa-f]{1,4}){0,2}:((25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)(\\.(25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)){3}))|:))|(([0-9A-Fa-f]{1,4}:){2}(((:[0-9A-Fa-f]{1,4}){1,5})|((:[0-9A-Fa-f]{1,4}){0,3}:((25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)(\\.(25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)){3}))|:))|([0-9A-Fa-f]{1,4}:){1}(((:[0-9A-Fa-f]{1,4}){0,4}:((25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)(\\.(25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)){3}))|((:[0-9A-Fa-f]{1,4}){1,6})|:)|(:(((:[0-9A-Fa-f]{1,4}){1,7})|((:[0-9A-Fa-f]{1,4}){0,5}:((25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)(\\.(25[0-5]|2[0-4]\\d|1\\d\\d|[1-9]?\\d)){3}))|:)))";
final String string = "1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000\n"
+ " link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00\n"
+ " inet 127.0.0.1/8 scope host lo\n"
+ " valid_lft forever preferred_lft forever\n"
+ " inet6 ::1/128 scope host \n"
+ " valid_lft forever preferred_lft forever\n"
+ "2: enp4s0f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000\n"
+ " link/ether 00:17:31:f1:98:3c brd ff:ff:ff:ff:ff:ff\n"
+ "3: enp4s0f1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000\n"
+ " link/ether 00:17:31:f1:98:3d brd ff:ff:ff:ff:ff:ff\n"
+ "4: enp5s0f0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000\n"
+ " link/ether 00:27:9e:b5:e6:da brd ff:ff:ff:ff:ff:ff\n"
+ " inet 5.2.14.1/29 brd 5.2.1.255 scope global noprefixroute enp5s0f0\n"
+ " valid_lft forever preferred_lft forever\n"
+ " inet6 fe80::5473:d653:a319:3d25/64 scope link noprefixroute \n"
+ " valid_lft forever preferred_lft forever\n"
+ "5: enp5s0f1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000\n"
+ " link/ether 00:26:9e:b5:e6:db brd ff:ff:ff:ff:ff:ff\n"
+ "27: ip_vti0@NONE: <NOARP> mtu 1480 qdisc noop state DOWN group default qlen 1000\n"
+ " link/ipip 0.0.0.0 brd 0.0.0.0\n"
+ "38: tunl0@NONE: <NOARP> mtu 1480 qdisc noop state DOWN group default qlen 1000\n"
+ " link/ipip 0.0.0.0 brd 0.0.0.0\n"
+ "50: tap0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN group default qlen 100\n"
+ " link/ether ea:04:cd:c5:81:fa brd ff:ff:ff:ff:ff:ff\n"
+ " inet 10.1.128.2/21 brd 10.1.135.255 scope global tap0\n"
+ " valid_lft forever preferred_lft forever\n"
+ " inet6 fe80::e804:cdff:fec5:81fa/64 scope link \n"
+ " valid_lft forever preferred_lft forever\n"
+ "fe80:0000:0000:0000:0204:61ff:fe9d:f156 // full form of IPv6\n"
+ "fe80:0:0:0:204:61ff:fe9d:f156 // drop leading zeroes\n"
+ "fe80::204:61ff:fe9d:f156 // collapse multiple zeroes to :: in the IPv6 address\n"
+ "fe80:0000:0000:0000:0204:61ff:254.157.241.86 // IPv4 dotted quad at the end\n"
+ "fe80:0:0:0:0204:61ff:254.157.241.86 // drop leading zeroes, IPv4 dotted quad at the end\n"
+ "fe80::204:61ff:254.157.241.86 // dotted quad at the end, multiple zeroes collapsed\n\n"
+ "In addition, the regular expression matches these IPv6 forms:\n\n"
+ "::1 // localhost\n"
+ "fe80:: // link-local prefix\n"
+ "2001:: // global unicast prefix\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}