using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?ms)^DISK\=\""(?<DISK>[^\""]+)\""\s+NAME\=\""(?<NAMA>[^\""]+)\""\s+HCTL\=\""(?<HCTL>[^\""]+)\""\s+TYPE\=\""(?<TYPE>[^\""]+)\""\s+VENDOR\=\""(?<VENDOR>[^\""]+)\""\s+SIZE\=\""(?<SIZE>[^\""]+)\""\s+SCSIHOST\=\""(?<SCSIHOST>[^\""]+)\""\s+CHANNEL\=\""(?<CHANNEL>[^\""]+)\""\s+ID\=\""(?<ID>[^\""]+)\""\s+LUN\=\""(?<LUN>[^\""]+)\""\s+BOOTDISK\=\""(?<BOOTDISK>[^\""]+)\""";
string input = @"DISK=""/dev/sda"" NAME=""sda"" HCTL=""0:0:0:0"" TYPE=""disk"" VENDOR=""VMware "" SIZE=""210G"" SCSIHOST=""0"" CHANNEL=""0"" ID=""0"" LUN=""0"" BOOTDISK=""TRUE""
DISK=""/dev/sdb"" NAME=""sdb"" HCTL=""0:0:1:0"" TYPE=""disk"" VENDOR=""VMware "" SIZE=""100G"" SCSIHOST=""0"" CHANNEL=""0"" ID=""1"" LUN=""0"" BOOTDISK=""FALSE""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}