const regex = /(?ms)^DISK\=\"(?<DISK>[^\"]+)\"\s+NAME\=\"(?<NAMA>[^\"]+)\"\s+HCTL\=\"(?<HCTL>[^\"]+)\"\s+TYPE\=\"(?<TYPE>[^\"]+)\"\s+VENDOR\=\"(?<VENDOR>[^\"]+)\"\s+SIZE\=\"(?<SIZE>[^\"]+)\"\s+SCSIHOST\=\"(?<SCSIHOST>[^\"]+)\"\s+CHANNEL\=\"(?<CHANNEL>[^\"]+)\"\s+ID\=\"(?<ID>[^\"]+)\"\s+LUN\=\"(?<LUN>[^\"]+)\"\s+BOOTDISK\=\"(?<BOOTDISK>[^\"]+)\"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?ms)^DISK\\=\\"(?<DISK>[^\\"]+)\\"\\s+NAME\\=\\"(?<NAMA>[^\\"]+)\\"\\s+HCTL\\=\\"(?<HCTL>[^\\"]+)\\"\\s+TYPE\\=\\"(?<TYPE>[^\\"]+)\\"\\s+VENDOR\\=\\"(?<VENDOR>[^\\"]+)\\"\\s+SIZE\\=\\"(?<SIZE>[^\\"]+)\\"\\s+SCSIHOST\\=\\"(?<SCSIHOST>[^\\"]+)\\"\\s+CHANNEL\\=\\"(?<CHANNEL>[^\\"]+)\\"\\s+ID\\=\\"(?<ID>[^\\"]+)\\"\\s+LUN\\=\\"(?<LUN>[^\\"]+)\\"\\s+BOOTDISK\\=\\"(?<BOOTDISK>[^\\"]+)\\"', 'gm')
const str = `DISK="/dev/sda" NAME="sda" HCTL="0:0:0:0" TYPE="disk" VENDOR="VMware " SIZE="210G" SCSIHOST="0" CHANNEL="0" ID="0" LUN="0" BOOTDISK="TRUE"
DISK="/dev/sdb" NAME="sdb" HCTL="0:0:1:0" TYPE="disk" VENDOR="VMware " SIZE="100G" SCSIHOST="0" CHANNEL="0" ID="1" LUN="0" BOOTDISK="FALSE"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}