import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b[A-Za-z]+\\b";
final String string = "Ὁμώνυμα λέγεται Aequivoca dicuntur ὧν ὄνομα μόνον κοινόν, quorum nomen solum commune est\n"
+ "ὁ δὲ κατὰ τοὔνομα λόγος τῆς οὐσίας ἕτερος secundum nomen vero substantiae ratio diversa, οἷον ζῷον ut animal ὅ τε ἄνθρωπος καὶ τὸ γεγραμμένον homo et quod pingitur· ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}