$re = '/(\S+?):([^:]*?<.*>|.+?)(?:,|$)/';
$str = 'document-name:string,document-type:string,description:string,initiative-name:string,milestone:struct<foo:struct<a:bar,b:baz>,name:string>,size:int';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);