re = /(\S+?):([^:]*?<.*>|.+?)(?:,|$)/
str = 'document-name:string,document-type:string,description:string,initiative-name:string,milestone:struct<foo:struct<a:bar,b:baz>,name:string>,size:int'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end