$re = '/(?s)^(?<var>.*?(?=\| (?:table|stats)|$))/m';
$str = 'search foo bar | table _time Action Direction
search foo bar hello hi ciao 1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);