re = /(?s)^(?<var>.*?(?=\| (?:table|stats)|$))/m
str = 'search foo bar | table _time Action Direction
search foo bar hello hi ciao 1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end