Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(?<!(?:\\{2})*\\)(?:(?<begin_capture>[\(])(?<begin_capture_modifier>(?=[<][a-z_A-Z]+[>])|(?!\?(?:<?[=!]|:)))|(?<begin_non_capture>\((?=\?(?:<?[=!]|:))))|(?:(?<end>\)))
/
gm
Test String
New
// Basic - Repeat Delimiters /^((?:([gimsuy])(?!.*\\2))*)/gm // Basic - Nested - Captured | Non-captured ^(?:(// +)(?:(@noframes)([ \t]*$)|(@(?:include|match|grant|require))([\t ]+)(?:(https?.+?)|(.+))(\**)([ \t]*)|(^//[ \t]+)(@(?:author|name(?:space)?|version|description))([ \t]+)(.+?)([ \t]*)|(^//[ \t]+)(@resource)([ \t]+)(\S+)([ \t]+)(\S+)([ \t]*))(\n(?://[ \t]*\n)*)) // Basic - Captured | Non-captured | Lookbehind Positive (?<=^[ \t]*)(//)([ ])(?<capture_name>)(Case:)([ \t]+)(.*\S)([ \t]*)?$ // Complex (?<=^[ \t]*)(//)([ ])(Case:)([ \t]+)(.*\S)([ \t]*)?$ ^(?:(?:(?:[0]*|[0]*1)(?=$))|(?:(?:[0]*|[0]*1(?[1-9]+)))?[\.][\d]+)$ ^((?:[ ]{2})*[ ])([#])([ ]+)(?:(@param)([ ]+)(?:([\$][\d\*@$?&]+))(\??)(?:(:)([\t ]+)(\w+))?(?:([ ]+)([=][>])([ ]+)(?:([A-Za-z_-](?:[<][^\n>]+[>]|[A-Za-z_-]*[^\n]*?))(?:([ ]+)(?:(@desc)|([<]\?))([ ]+)(.+?))?))([ ]*)|(@return)(?:([ ]+)([=][>])([ ]+)(?:([A-Za-z_][A-Za-z_]*)(.*?)(?:([ ]+)(?:(@desc)|([<]\?))([ ]+)(.+?))?)))$
Substitution
Processing...
\n - $begin_capture