import Foundation
let pattern = #"(?<!(?:\\{2})*\\)(?:(?<begin_capture>[\(])(?<begin_capture_modifier>(?=[<][a-z_A-Z]+[>])|(?!\?(?:<?[=!]|:)))|(?<begin_non_capture>\((?=\?(?:<?[=!]|:))))|(?:(?<end>\)))"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
// Basic - Repeat Delimiters
/^((?:([gimsuy])(?!.*\\2))*)/gm
// Basic - Nested - Captured | Non-captured
^(?:(// +)(?:(@noframes)([ \t]*$)|(@(?:include|match|grant|require))([\t ]+)(?:(https?.+?)|(.+))(\**)([ \t]*)|(^//[ \t]+)(@(?:author|name(?:space)?|version|description))([ \t]+)(.+?)([ \t]*)|(^//[ \t]+)(@resource)([ \t]+)(\S+)([ \t]+)(\S+)([ \t]*))(\n(?://[ \t]*\n)*))
// Basic - Captured | Non-captured | Lookbehind Positive
(?<=^[ \t]*)(//)([ ])(?<capture_name>)(Case:)([ \t]+)(.*\S)([ \t]*)?$
// Complex
(?<=^[ \t]*)(//)([ ])(Case:)([ \t]+)(.*\S)([ \t]*)?$
^(?:(?:(?:[0]*|[0]*1)(?=$))|(?:(?:[0]*|[0]*1(?[1-9]+)))?[\.][\d]+)$
^((?:[ ]{2})*[ ])([#])([ ]+)(?:(@param)([ ]+)(?:([\$][\d\*@$?&]+))(\??)(?:(:)([\t ]+)(\w+))?(?:([ ]+)([=][>])([ ]+)(?:([A-Za-z_-](?:[<][^\n>]+[>]|[A-Za-z_-]*[^\n]*?))(?:([ ]+)(?:(@desc)|([<]\?))([ ]+)(.+?))?))([ ]*)|(@return)(?:([ ]+)([=][>])([ ]+)(?:([A-Za-z_][A-Za-z_]*)(.*?)(?:([ ]+)(?:(@desc)|([<]\?))([ ]+)(.+?))?)))$
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\n - $begin_capture"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)