import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<day>0?[1-9]|[12][0-9]|3[01])(?>.{1})(?(?=0?[469]|11)(?<!31(?>.{1}))|)(?(?=0?2)(?<!3[01](?>.{1})))(?(?=0?2(?>.{1})\\d\\d(?!00)(?:[02468][048]|[13579][26]))|(?<!29(?>.{1})))(?<month>0?[1-9]|1[12])(?>.{1})(?<year>19[0-9][0-9]|20[0-9][0-9]|[0-9]{2,4})(?!\\d)";
final String string = "29.02.1704\n\n"
+ "01.01.1987 // ok\n"
+ "101.01.19870 // bad- too many numbers\n"
+ "1.1.1987 // ok\n"
+ "32.02.1987 // bad- 32 feb\n"
+ "29.02.2001 // bad\n"
+ "0.0.1987 // bad\n"
+ "0.13.1987 // bad\n"
+ "8.8.8.8 // bad\n"
+ "31.04.1987 // bad\n"
+ "31.06.1987 // bad\n"
+ "31.09.1987 // bad\n"
+ "31.11.1987 // bad\n"
+ "30.02.1987 // bad\n"
+ "29.02/1987 // bad\n"
+ "29.02.1988 // ok\n"
+ "29.02.2000 // bad\n"
+ "29.02.2408 \n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}