package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Detalhamento de Serviços[\D]+(\d+-\d+-\d+)`)
var str = `Detalhamento de Serviços nº: 999-99999-9999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}