re = /Detalhamento de Serviços[\D]+(\d+-\d+-\d+)/m
str = 'Detalhamento de Serviços nº: 999-99999-9999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end