using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([A-Za-z0-9._]*)@([A-Za-z0-9_.]*)";
string input = @"lubo_mir.ni_kl@gma.il.com
frANta@krbec.cz
_info_@_domain_.co.uk";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}