import re
regex = re.compile(r"^([A-Za-z0-9._]*)@([A-Za-z0-9_.]*)", flags=re.MULTILINE)
test_str = ("lubo_mir.ni_kl@gma.il.com\n"
"frANta@krbec.cz\n"
"_info_@_domain_.co.uk")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")