# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\x1B7)?(\x9B|\x1B\[)[0-?]*[ -\/]*[@-~](\x1B[=>]\r?)*"
test_str = ("show configuration\n"
"[?1h=\n"
"interfaces {[m\n"
" ethernet eth1 {[m\n"
" duplex auto[m\n"
" address 172.22.108.100/24[m\n"
" speed auto[m\n"
" smp_affinity auto[m\n"
" }[m\n"
" loopback lo {[m\n"
" }[m\n"
"}[m\n"
"system {[m\n"
" time-zone UTC[m\n"
" syslog {[m\n"
" }[m\n"
" config-management {[m\n"
" commit-revisions 20[m\n"
" }[m\n"
" host-name dm2500[m\n"
"[m\n"
"BLABLABLA\n"
"[K[?1l>admin@dm2500:~$ ")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.