#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((1?[0-9]{0,4})|((20(([0-3][0-9]{0,2})|(4[0-7][0-9])))))$"
Local $sString = "0" & @CRLF & _
"20479" & @CRLF & _
"20489" & @CRLF & _
"20469" & @CRLF & _
"1999" & @CRLF & _
"1" & @CRLF & _
"12" & @CRLF & _
"99" & @CRLF & _
"1234" & @CRLF & _
"9785" & @CRLF & _
"20000" & @CRLF & _
"30000" & @CRLF & _
"2100" & @CRLF & _
"21000" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")