re = /^((1?[0-9]{0,4})|((20(([0-3][0-9]{0,2})|(4[0-7][0-9])))))$/m
str = '0
20479
20489
20469
1999
1
12
99
1234
9785
20000
30000
2100
21000
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end