using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?!.*([IXCM])(\1{3}))(?!.*([VLD])(\3))^[IVXLCDM]+$";
string input = @"VIIIIIII";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}