$re = '/{([a-z])\?}/m';
$str = 'aaaa{v?}a $1?{23ru{n?}kkkk';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;