import re
regex = re.compile(r"{([a-z])\?}", flags=re.MULTILINE)
test_str = "aaaa{v?}a $1?{23ru{n?}kkkk"
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)