package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z]{1}[\d]{1}[a-zA-Z]{1}([- ])?[\d]{1}[a-zA-Z]{1}[\d]{1}$`)
var str = `s4k 6J9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}