re = /^[a-zA-Z]{1}[\d]{1}[a-zA-Z]{1}([- ])?[\d]{1}[a-zA-Z]{1}[\d]{1}$/m
str = 's4k 6J9'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end