import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=\\[\\[)(?!https?:\\/\\/)[^][|]+(?=(?:\\|[^][]*)?]])";
final String string = "[[my_page]]\n\n"
+ "[[my_other_page|this is my other page]]\n\n"
+ "[[http://your_page|this is your page]]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}