re = /(?<=\[\[)(?!https?:\/\/)[^][|]+(?=(?:\|[^][]*)?]])/m
str = '[[my_page]]
[[my_other_page|this is my other page]]
[[http://your_page|this is your page]]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end