#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[^<]?(https?:\/\/(?:www\.)?[-a-zA-Z0-9@:%._\+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}\b(?:[-a-zA-Z0-9()@:%_\+.~#?&\/\/=]*))[^>]?$"
Local $sString = "https://www.google.com/" & @CRLF & _
"https://www.fakesite.co.in" & @CRLF & _
"https://www.fakesite.co.uk" & @CRLF & _
"<https://www.fakesite.co.uk>" & @CRLF & _
"<https://www.google.com/>"
Local $sSubst = "<$1>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)