$re = '/^[^<]?(https?:\/\/(?:www\.)?[-a-zA-Z0-9@:%._\+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}\b(?:[-a-zA-Z0-9()@:%_\+.~#?&\/\/=]*))[^>]?$/m';
$str = 'https://www.google.com/
https://www.fakesite.co.in
https://www.fakesite.co.uk
<https://www.fakesite.co.uk>
<https://www.google.com/>';
$subst = "<$1>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;