use strict;
my $str = 'https://www.google.com/
https://www.fakesite.co.in
https://www.fakesite.co.uk
<https://www.fakesite.co.uk>
<https://www.google.com/>';
my $regex = qr/^[^<]?(https?:\/\/(www\.)?[-a-zA-Z0-9@:%._\+~#=]{1,256}\.[a-zA-Z0-9()]{1,6}\b([-a-zA-Z0-9()@:%_\+.~#?&\/\/=]*))[^>]?$/mp;
my $subst = '<$1>';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";