#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!^0(e[0-9]|[EPTGMK]i?|)$)([0-9]+)(|[EPTGMK]i?|e[0-9]+)$"
Local $sString = "0K" & @CRLF & _
"0Ki" & @CRLF & _
"0" & @CRLF & _
"0e0" & @CRLF & _
"" & @CRLF & _
"1K" & @CRLF & _
"10K" & @CRLF & _
"100K" & @CRLF & _
"1000Ki" & @CRLF & _
"" & @CRLF & _
"1Ki" & @CRLF & _
"10Ki" & @CRLF & _
"100Ki" & @CRLF & _
"1000Ki" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"10" & @CRLF & _
"100" & @CRLF & _
"1000" & @CRLF & _
"" & @CRLF & _
"1e0" & @CRLF & _
"1e1" & @CRLF & _
"10e10" & @CRLF & _
"100e100"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")