$re = '/^(?!^0(e[0-9]|[EPTGMK]i?|)$)([0-9]+)(|[EPTGMK]i?|e[0-9]+)$/m';
$str = '0K
0Ki
0
0e0
1K
10K
100K
1000Ki
1Ki
10Ki
100Ki
1000Ki
1
10
100
1000
1e0
1e1
10e10
100e100';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);