#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\n1\s(\d{2,8})\s(\d{1,3}(?:\.\d{3})*(?:\,\d+))\s(\w{1,10})\s(\d{1,3}(?:\.\d{3})*(?:\,\d+))\s(\d{1,3}(?:\.\d{3})*(?:\,\d+))\s(\w{3})(?:\r?\n(?!Ihre).*)*\r?\nIhre Art.-Nr.\s(\d+)(?:\r?\n(?!DeliveryDate:|incl\.).*)*\r?\n(?:DeliveryDate:\s(\d{2}.\d{2}.\d{4}))?(?:\r?\n(?!incl\.).*)*\r?\nincl\.(?:ExtraCharge\r?\n\s*entspricht:\s(\d{1,3}(?:\.\d{3})*(?:\,\d+))\s(\w{1,10}))?"
Local $sString = "" & @CRLF & _
"1 123456 25,00 Stck 100,00 2.500,00 EUR" & @CRLF & _
"" & @CRLF & _
". . . some text" & @CRLF & _
"" & @CRLF & _
"Ihre Art.-Nr. 1690431" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
". . . some text" & @CRLF & _
"" & @CRLF & _
"incl." & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"1 123456 25,00 Stck 100,00 2.500,00 EUR" & @CRLF & _
"" & @CRLF & _
". . . some text" & @CRLF & _
"" & @CRLF & _
"Ihre Art.-Nr. 1690431" & @CRLF & _
"" & @CRLF & _
"DeliveryDate: 21.11.2019" & @CRLF & _
"" & @CRLF & _
". . . some text" & @CRLF & _
"" & @CRLF & _
"incl.ExtraCharge" & @CRLF & _
"" & @CRLF & _
"entspricht: 222,00 EUR"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")