$re = '/\n1\s(\d{2,8})\s(\d{1,3}(?:\.\d{3})*(?:\,\d+))\s(\w{1,10})\s(\d{1,3}(?:\.\d{3})*(?:\,\d+))\s(\d{1,3}(?:\.\d{3})*(?:\,\d+))\s(\w{3})(?:\r?\n(?!Ihre).*)*\r?\nIhre Art.-Nr.\s(\d+)(?:\r?\n(?!DeliveryDate:|incl\.).*)*\r?\n(?:DeliveryDate:\s(\d{2}.\d{2}.\d{4}))?(?:\r?\n(?!incl\.).*)*\r?\nincl\.(?:ExtraCharge\r?\n\s*entspricht:\s(\d{1,3}(?:\.\d{3})*(?:\,\d+))\s(\w{1,10}))?/m';
$str = '
1 123456 25,00 Stck 100,00 2.500,00 EUR
. . . some text
Ihre Art.-Nr. 1690431
. . . some text
incl.
1 123456 25,00 Stck 100,00 2.500,00 EUR
. . . some text
Ihre Art.-Nr. 1690431
DeliveryDate: 21.11.2019
. . . some text
incl.ExtraCharge
entspricht: 222,00 EUR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);