use strict;
my $str = '123abd //should match 123
abc345 //should match 234
ab2123cd // should match 2123
{2}: Should NOT Match. //My regex Works
{34: Should NOT Match. //My regex matches 4 in {34
45}: Should NOT Match. //My regex matches 4 in {45
{123}: Should NOT Match. //My regex matches 2 in {123}
1st should NOT match
3th should NOT match, since it\'s wrong anyway
1nd should NOT match, since it\'s wrong anyway
14th //should NOT Match
14 th should Match
like 1st, 2nd, etc or #1, #2, etc';
my $regex = qr/(?<![#\d{])\d+(?!\w*(?:}|(?:st|th|rd|nd)\b))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}