$re = '/(?<![#\d{])\d+(?!\w*(?:}|(?:st|th|rd|nd)\b))/m';
$str = '123abd //should match 123
abc345 //should match 234
ab2123cd // should match 2123
{2}: Should NOT Match. //My regex Works
{34: Should NOT Match. //My regex matches 4 in {34
45}: Should NOT Match. //My regex matches 4 in {45
{123}: Should NOT Match. //My regex matches 2 in {123}
1st should NOT match
3th should NOT match, since it\'s wrong anyway
1nd should NOT match, since it\'s wrong anyway
14th //should NOT Match
14 th should Match
like 1st, 2nd, etc or #1, #2, etc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);