re = /^(?![#\/.]).*(?<![#\/.])$/m
str = 'abcdef
/fooo
foobar/
/foobar/
hash#in the middle
foo.bar
#hashtag
blah.
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end