#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9@\-\.]*$"
Local $sString = "t3st" & @CRLF & _
"t#st" & @CRLF & _
"p@ssw0rd" & @CRLF & _
"t3sting@@@@akldsxfkshgkjaehfk" & @CRLF & _
"p23549$adk" & @CRLF & _
"dskalf" & @CRLF & _
"adv-admin" & @CRLF & _
"adv$-admin" & @CRLF & _
"eped360@gmail...comhelloco" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")