package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9@\-\.]*$`)
var str = `t3st
t#st
p@ssw0rd
t3sting@@@@akldsxfkshgkjaehfk
p23549$adk
dskalf
adv-admin
adv$-admin
eped360@gmail...comhelloco
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}