const regex = /^(?:.*?\bRationale-|Normal|List Paragraph\t(?:\d+\)[ \t]*)?)[ \t]*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:.*?\\bRationale-|Normal|List Paragraph\\t(?:\\d+\\)[ \\t]*)?)[ \\t]*', 'gm')
const str = `List Paragraph 36) Rationale-1 - Details on the context:
List Paragraph 37) None.
Normal
List Paragraph 38) 2 - Statement complements:
List Paragraph 39) Blablablabla
List Paragraph (1) Blablablabla
List Paragraph (2) Blablablabla
List Paragraph (3) Blablablabla
List Paragraph (4) Blablablabla
List Paragraph (5) Blablablabla
List Paragraph (6) Blablablabla
List Paragraph (7) Blablablabla
Normal
List Paragraph 40) Blablablabla
Normal
List Paragraph 41) 3 - Statement justification:
List Paragraph 42) Blablablabla
Normal
List Paragraph 43) Blablablabla
List Paragraph 44) Blablablabla
List Paragraph 45) Blablablabla
List Paragraph 46) Attached Files: Rationale-
Normal`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);